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Introduction (Downloading KompoZer) 

KompoZer is a complete web authoring system that combines web file 
management and easy-to-use WYSIWYG (What You See Is What You Get) web 
page editing.  

Step 1  
Open your browser go browse to http://kompozer.net/ . 

You should see something like Figure 1: 

Figure 1: KompoZer Home Page 
 
Click on the “Download!” button, which will bring you to the download page. 
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Step 2  
Choose the program which suits your Operating System (OS). For example, If 
you are using Microsoft Windows, choose kompozer-0.7.10-win32.zip. (NOTE: 
Name of the file is correct as of the writing of this guide; 31 March 2009 and may 
subject to change).  
 
In this example we use the Windows OS. 

Figure 2: Kompozer Download page 
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Step 3  
Once you have clicked the respective file according to your OS, the browser 
should redirect you to another page where the download will be automatically 
prompted. Save your file to an easily accessible location.  
 

 
Figure 3: Save the file 
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Figure 4: Save to Desktop for easy access 
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Step 4  
Once the download is complete, right click the downloaded file and click ‘Extract 
All’ to your chosen location. 
 

 
Figure 5: Extract the downloaded file 

 
Step 5  
You will be prompted with the following window. Click ‘Next’ until it finishes 
extracting. (Refer to Figure 6 & 7). 
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Figure 6: Click 'Next' until you see extract completed 

 

 
Figure 7: Extract completed 
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Step 6  
Open the extracted folder and open the kompozer.exe. 
 

 
Figure 8: Double-click on the highlighter program 
 
You should see something similar to Figure 9: 
 

 
Figure 9: KompoZer Program 
 
Now, you are ready to begin editing your websites. But before that, ensure you 
have downloaded your websites from the FTP to your computer. Firstly, this is to 
improve the efficiency of KompoZer. Secondly, this is to ensure your original 
website on the FTP are available so that your visitors can still visit your website. 
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CoreFTP (Downloading Your Websites) 
 
Step 1  
Double-click on the CoreFTP. 
 

 
Figure 10: CoreFTP 

 
Step 2  
When the programs start, there will be a site manager screen. Alternatively, you 
can select the button to bring up the site manager panel. You will be required to 
fill in the following particulars for connection to the FTP server. 
 

 
Figure 11: *Site Manager Button 

• Site Name  (This name of your website.) 
• HOST/IP/URL (The URL of your FTP server, which given to you.) 
• Username  (The given Username, which would the one used for entering 

your Cpanel.) 
• Password  (The given Password, which would be the one used for 

entering your Cpanel.) 
 
The rest are recommended to be at default setting. 

 
Figure 12: Site Manager 
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Step 3  
After successfully connecting, you should see something similar to Figure 13. 
 

 
Figure 13: FTP Display 
 
The left display panel (the one enclose in green  border as shown in Figure 13), 
is the location of your files. You can choose where you want to save your 
downloaded websites from the FTP. 
 
The right display panel (the one enclose in red  border as shown in Figure 13), 
will display the folders on your FTP server. 
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Step 4  
Locate the file ‘www’ on the right display panel and double-click on it. 
 

 
Figure 14: 'www' folder on the FTP 
 
Step 5  
Once entered, select all the files in the ‘www’ folder except the ones (enclose in 
red ) as shown in Figure 15. 
 

 
Figure 15: DO NOT SELECT THE FOLDERS IN RED 
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Step 6  
Click the ‘Blue Left Arrow’ to begin downloading on to your computer. 
 

 
Figure 16: Click this blue arrow to download the selected files 
 
Now, you are ready to begin editing your websites using KompoZer. 
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KompoZer (Editing the Words) 
 
Step 1  
Open up the kompozer.exe. (Refer to Page 9 for instructions). 
 
Step 2  
Go to File > Open File and browse to the location where you downloaded the 
FTP files. 
 

 
Figure 17: File > Open File 
 
Step 3  
Select the page which you want to edit, in this example we use index.html which 
is the home page of the website. 
 

 
              Figure 18: Select a page to edit 
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Step 4  
Now, you should be able to see the index.html displaying on KompoZer. 
 

 
Figure 19: A page on KompoZer 
 
Here’s a zoomed in image, we are going to editing the sentence, ‘Welcome to a 
world’ to ‘Greetings to a location’. 
 

 
Figure 20: Zoomed-in image 
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Step 5  
Using KompoZer, click once on the word that you wish to edit. Notice the blinking 
cursor (Figure 20). Now press ‘Backspace’ on the keyboard and change the word 
to your desired word. After that, go to File > Save. (Refer to Figure 23) to save 
your changes.  
 

 
Figure 21: Editing a sentence 

 

 
Figure 22: Changed to 'Greetings to a location’ 
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Figure 23: Saving your changes 
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KompoZer (Editing the Background Colors) 
 
Now, we are going to edit the color of the background. In this example, the 
background is an image, but we will show you how to remove it and add in a 
color. 
 

 
Figure 24: This background in this page is to be edited 

 
Step 1  
Locate a ‘Painting’ icon labeled ‘CaScadeS’ at the top panel and click on it. 
 

 
Figure 25: Locate this icon, click on it 
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Step 2  
A ‘CSS Stylesheets’ window will be prompted to you. Locate either style.css, 
main.css or default.css. These are the files that contain the background 
properties. Once located, double click on it. 
 

 
Figure 26: Look out for style.css / default.css / main.css file 
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Step 3  
A list of words should be expanded as shown in Figure 27. Look for the tag 
‘body’  and click on it. 
 

 
Figure 27: Click on the ‘body’ tag 
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Step 4  
Click on the Background tab, in this case the ‘Image:’ is not empty. (Refer to 
Figure 29) Delete the field since we only want to change the background color 
and not the background image. 
 

 
Figure 28: Click on the ‘Background’ tab 
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Figure 29: Remove this field if it is filled 
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Step 5  
Now, click on the square as shown in Figure 30. A ‘Block Background Color ’ 
window should be prompted. (Refer to Figure 31) Choose your desire color and 
press ‘OK’ button. (Refer to Figure 32) Leave the other options as default. 
Remember to save your changes once you are satisfied. 
 

 
Figure 30: Click on this square 
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Figure 31: This window should popped up 

 

 
Figure 32: Choose your desired color and press 'OK' 
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Figure 33: Before changing the background 

 

 
Figure 34: After changing the background 
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KompoZer (Undoing the Changes) 
 
If you have made any mistakes or dislike your changes, do not worry. Just make 
sure KompoZer is not closed  after you have made the changes. Click on Edit > 
Undo to undo the changes. 
 
 
 
 

 
Figure 35: Undoing Changes 
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KompoZer (Inserting & Deleting Pictures) 
 
Now we will demonstrate how to change your pictures on your webpages. 
 
Step 1  
Open the webpage that you need to insert or delete picture. (Refer to Page 14 if 
you are not sure). 
 
Step 2  
First, to delete a picture, select it, notice the grid that shows up (Refer to Figure 
36), press the ‘Delete’ key on your keyboard to delete. 
 

 
Figure 36: *NOTE the white grid when you select the picture 
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Step 3  
We will now insert a picture. Go to Insert > Image, a window will pop up as 
shown in Figure 38. 
 

 
Figure 37: Insert > Image 

 

 
Figure 23: Click on the folder icon to browse for your image 

 
Make sure your image is in a folder eg, img or image, this is to ensure 
manageability and also ensure that the images are linked correctly. Ensure the 
‘URL is relative to page location’  checkbox is checked. (Refer to Figure 38) 
This helps the website to load the respective images online. 
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Leave the other options as default and press ‘OK’. Save your changes after you 
are satisfied with it. 
 

 
Figure 24: Browse for your desired picture 

 

 
Figure 25: Picture has been changed successfully 
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KompoZer (Inserting a Link) 
Inserting a link from one page to another can be done in a few simple steps. Now 
we will show you how using KompoZer. 
 
Step 1  
Open the webpage you want to insert/edit a link. (Refer to Page 14 on how to 
open a webpage). 
 
Step 2  
Select the word that you want to add a link to. 
 

 
    Figure 26: Select the word 
 
Step 3  
With the word selected, right click on it. You should see a list of options as shown 
in Figure 42. Choose ‘Remove Links’ if you want to clear a link, else click on 
‘Create Link…’  
 

 
      Figure 27: Right-click on the selected word 
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Step 4  
Now, a ‘Link Properties’  window should be prompted. Type the name of the 
page you want the word to link to. Eg, index.html, mypage.html, abc.html. In 
addition, you can also type the URL of the website eg, http://www.mypage.com, 
http://www.testpage.com/index.html.   
 
Alternately, you can choose to click on the folder icon as shown in Figure 43 and 
browse for your webpage that you want to link. Leave all other options as default. 
 

 
Figure 28: Type the webpage or browse for it 
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Figure 29: Browsing for the webpage 

 
We recommend all the .html files to be in the same location. Eg, index.html’s 
location is the same as contact.html ‘s location. This enhances manageability 
and enable KompoZer to link it correctly. 
 
Do not forget to save your changes or else the changes will not be made. 
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Viewing/Checking the Webpages 
Very often, we will check the webpages that we have edited. Although KompoZer 
is a WYSIWYG (What You See Is What You Get) web page editor, there are 
times when they differ when you see them on the webpage. 
 
Step 1  
To view the webpages, go to your folder where you save your webpages. 
 
Step 2  
Look for index.html and double-click to open it. Check through the webpages for 
any mistakes. Eg, those changes you have made whether they have been 
modified. 
 

 
Figure 30: Open index.html and check for mistakes 
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CoreFTP (Uploading Your Websites) 
 
Now that you have made all the changes to your satisfaction, you are ready to 
upload your website for your visitors. 
 
Step 1  
Open Core FTP, connect to the FTP server, refer to Page 10 on how to connect. 
 
Step 2  
Once successful, browse the left display panel to the location where your edited 
webpages are. Click on the box as shown in Figure 46 and browse to the folder. 
 
 

 
Figure 31: Click the box to browse to location of webpages 

 
 
 
 
 

 
Figure 32: Browsing to the folder 
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Step 3  
In addition, on the right display panel, browse the right display panel into /www/ 
as shown in Figure 48. 
 

 
Figure 33: Right Display Panel to /www/ 

Step 4   
Now, you are prepared to start uploading your edited webpages. After you have 
selected the location of your webpages, select all the files except the ‘…’ as 
shown in Figure 49 in the left display panel. 
 

 
Figure 34: Left Display Panel select all the files except the '...' 
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Step 5  
Locate the “Right Blue Arrow” and click on it to start uploading on to the FTP 
server as shown in Figure 50. 
 

 
Figure 35: Upload to the FTP server 
 
Step 6  
If a window pops up as shown in Figure 51, click “Overwrite All”. 
 

 
Figure 36: Click "Overwrite All" 
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Step 7  
The uploading would take place and the status of it would be display at the 
bottom of the screen. Time taken of uploading varies on the sizes of your file. 
 

 
Figure 37: Uploading a file 

 
*when transferring, the Status column will be stated as “Xfering”. 
 
When the uploading is successful, the uploaded file can be seen on the window 
on the right display panel and the Status would be labeled “Success”. 
 

 
Figure 38: Upload completed 

 
Once all the files have been transferred, you can visit your website by going to 
www.your_site_name.com as stated when you connect to Core FTP. 
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Contact Us 
 
For further assistance, please contact our Technical Hotline @ 6100 3101 or visit 
our corporate office located in 3 Shenton Way, Shenton House, #02 – 01, 
Singapore 068805. 


